WMS Performance issues

Incident Report for Ongoing

Resolved

This incident has been resolved.
Posted May 19, 2025 - 16:00 CEST

Monitoring

We have identified high load on one of our servers, and have taken action to distribute the functionality over more servers.
Posted May 19, 2025 - 13:24 CEST

Investigating

We have been getting reports of performance issues.
We are currently investigating.
Posted May 19, 2025 - 12:50 CEST
This incident affected: WMS Application and API.