Issues with sending emails to Microsoft addresses

Incident Report for Ongoing

Resolved

This incident has been resolved.
Posted May 04, 2026 - 10:46 CEST

Update

We are in communication with Microsoft about the issues
Posted Apr 28, 2026 - 15:25 CEST

Investigating

We are currently experiencing issues with sending emails to Microsoft addresses such as hotmail/msn/live addresses. We are investigating the issue.
Posted Apr 28, 2026 - 09:16 CEST
This incident affected: WMS Application.