Performance issues

Incident Report for Ongoing

Resolved

This incident has been resolved.
Posted May 28, 2025 - 16:18 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 28, 2025 - 14:31 CEST

Update

We are continuing to investigate the issue.
Posted May 28, 2025 - 14:09 CEST

Investigating

We have been getting reports of performance issues from some of our customers. We are currently investigating.
Posted May 28, 2025 - 13:13 CEST
This incident affected: WMS Application.